Header file naming in XFce libs

  • February 3, 2004
  • Benedikt

While integrating the about dialog in libxfcegui4 I realized that we have three different naming schemes for public gobject header files in the base libs:

1. In libxfce4util we have a class named “XfceDesktopEntry” with a file name of xfce_desktop_entry.h

2. In libxfcegui4 we have classes whose names start with “Xfce” in files, like XfceFrameBox, in files named xfce_framebox.h (notice no ‘_’ between Frame and Box).

3. In libxfcegui4 there are also the Netk class, for example NetkClassGroup, with an interface file named netk-class-group.h

Should there be one consistent naming scheme for all public interface headers in XFce? I would prefer the third alternative, as this seems to be the standard. That way I no longer need to look into the include dirs how the header file is named, instead I can just get the header file name from looking at the class name.